I'm not a Klingon ( )
learn.microsoft.com/en-us/archive/blogs/shawnste
Shawn Steele's thoughts about Windows and .Net Framework globalization APIs
- Posts
- 184 from 1 Mar 2005 to 10 Apr 2019
- Posting
- archived, read-only
- Kind
- personal blog
- Feed
- https://learn.microsoft.com/en-us/archive/blogs/shawnste/feed.xml
2019 2
2018 6
2017 3
2016 1
2015 3
2014 3
2013 10
- Locale Builder v2.0 for Windows 8.1/Server 2012 R2 Released!
- Lego L3-G0
- How does IE handle the IDN2008 RFCs?
- Updates to "How to tell if the collation (sorting) version changed" in Windows NLS
- Testing for NLS sorting/collation behavior changes when calling JetAttachDatabase
- pIqaD Font for Bing's Klingon Translator
- Bing Translator, Klingon High Council, and Klingon Language Institute announce support for Klingon as a Bing Translator Option!
- Windows 8 Media Center and my Clock
- Slowing down searchfilterhost.exe on my Media Center box when Xbox 360 Extender is attached
- Converting text file code pages
2012 8
- Language packs and Windows RT (like microsoft surface or another Windows RT device) upgrades.
- Klingon Win8 Lock Screen: Might Sell Qurgh on Win8 After All :)
- Email Address Internationalization, aka: using UTF-8 in email, RFCs are published
- All Done With the Lego Wonder
- Building The Lego Wonder
- Like, what do you mean, there aren't any instructions?
- There's a Lego Cruise Ship in Building 85
- Use the Windows 8 Language Profile to pick YOUR language(s)
2011 5
2010 11
- How do I tell if a user's entering Unicode data into my ANSI app?
- IDNA - Is it fussball or fußball?
- Short Date Formats Don't Always Fit Neat Patterns
- Unicode 6.0 has a new Indian Rupee Symbol, how do I get it?
- Quick Custom Culture to Change Euro Currency Symbol
- The Square Boxes in My Blog's Title
- There're now "real" IDN TLDs....
- 4 IDN ccTLDs (country code top level domain)s have been approved.
- Shawn Dropped the Space Needle
- UTF-8 usage on web approaching 50%
- Most combining characters in a Unicode glyph/character/whatever
2009 16
- The FUD of IDN and Homographs
- SetLocaleInfo() is horrid, don't use it!
- IDNA2008 / IDNAbis on Windows 7, Vista, Net, etc.
- Visual Studio 2010 and .Net v4 Beta released
- Missing International Setting Registry Key?
- A Cool Hard Drive Fix
- Japanese Calendars, How do I Test Support for Additional Eras?
- Oversimplification of EAI/IMA (International eMail Addresses)
- What is Title Case?
- Alternate encoding names recognized by .Net / IE
-
- Writing "fields" of data to an encoded file.
- Locale Builder and Two Letter ISO name and Three Letter Windows Language Name
- Cheating to UNinstall Custom Cultures / Locales
- A Pet Peeve of Mine
- Don't use MB_COMPOSITE, MB_PRECOMPOSED or WC_COMPOSITECHECK
2008 18
- Front page uses windows-1252, shouldn't it be iso-8859-1?
- Our Unicode Globalization Windows Language Support Presentation
- Our Unicode & Globalization Silverlight Presentation
- How come Substring(0, xxx) matches something, but StartsWith returns false?
- World Wide Telescope is really cool
- Silverlight Time Zone World Clock (Very Beta) Demo
- Some Silverlight Links
- I'm at the Unicode Conference
- About working here
- Go Global Developer Center on MSDN
- How Come My "ț" (or Another Character) Doesn't Work in Code Page XXX?
- Where to Look Up Information About Microsoft Code Pages?
- Unicode use on the web
- Commenting on Comments
- Code page xxx isn't available on my (windows XP or 2003) computer, what happened?
- Server 2008 U+FFFD behavior for unknown or illegal UTF-8 sequences.
- MSDN Code Gallery Custom Locales
- Code pages and security issues
2007 35
- https://www.languagegeek.com/
- Cantonese and Manderin language tagging.
- zh-Hans, zh-Hant and the "old" zh-CHS, zh-CHT
- Michael has a blog about converting apps from ANSI to Unicode
- How do you make your regional and language options apply to new user accounts?
- What's a genitive month name anyway?
- "Windows Vista Command Line Configuration of International Settings" is on-line on MSDN
- Locale Builder Beta 2 is Available
- UTF-16, UTF-8 & UTF-32 update to conform with Unicode 5.0's security concerns.
- Vista international configuration document on-line
- I see my favorite Ansi function has the behavior I want.
- Almost dismasted
- Why can't we strip the diacritics?
- Encoder/Decoder Encoding fallbacks fail after 2GB of data has been converted
- Updated custom culture sample workaround for the .Net 2.0 Culture Name Change
- How to tell if the collation version changed.
- DateTime.Parse() and DateTime.TryParse() fail in some cases
- MLang & MSXML6 doesn't like UTF-7
- How do I get HKSCS 2004 characters from Big-5 in .Net?
- How do I get my ANSI based application to run correctly?
- Please avoid UTF-7
- Understanding locale & culture "display" names
- Garfield "It's All About..." Series App Compatibility and Windows Vista
- Configuring Regional and Language Options International Settings with command line automation
- Why Me? :-)
- DateTime.Parse() fails when separator is " " (space) in .Net v2.0 RTM
- Hacking Code Pages, or "How to Totally Hose Your Machine AND Your Data".
- .Net Framework Encoding Sample
- Code Pages, Unicode & Encodings
- New "stickies"
- Custom Cultures / Vista Custom Locales
- First day of week and the Vista Calendar Gadget
- Remember not to use strings for random byte sequences.
- Keyboard Layout Creator for Vista released.
- Locale Builder Beta Expired - Beta 2 now available
2006 35
- Problems compiling resources in .Net 2.0 apps after updates.
- Some custom locale examples.
- Expected names of Microsoft Windows "ANSI" Code Pages (Encodings)
- Vista changes .Net 2.0 Locale Names, sample work around custom cultures/locales
- Example of overriding your own Encoding.
- Rambling about RFC 4690 and IDN
- RFC 3066 has been replaced by RFC 4646
- Best Way to Make Your Own Encoding
- List of "ANSI" code pages used by Windows.
- RegionInfo objects are sensitive to a specific culture.
- VBScript's SetLocale doesn't know about new Vista locales.
- How do I get localization in JScript (JavaScript) in IE7?
- Does your web site die when it sees unexpected languages?
- Does "Everyone" Use IDN?
- MSDN Wiki is kind of cool.
- How's the CultureAndRegionInfoBuilder (CARIB) do that?
- Custom Locale and Custom Culture Limitations and Things That Work.
- Encoding.GetEncodings() has a couple "duplicate" names
- Oddities of LOCALE_SGROUPING, NumberGroupSizes and NUMBERFMT
- Pseudo Locales in Windows Vista Beta 2
- Calendar Assumptions: Why does Windows (or .Net) have 13 month names?
- What's with Encoding.GetMaxByteCount() and Encoding.GetMaxCharCount()? Part 2
- Custom cultures & resources; BCL Team Blog; also ResourceManager Video
- I changed an earlier post
- Change to Unicode Encoding for Unicode 5.0 conformance
- Internet Explorer has more explicit language names in Windows Vista
- June 2006 MSDN, CLR Inside Out
- Custom Locale Builder Tool Beta Now Available!
- Cheating to Install Custom Cultures - Updated 20 June 2006
- More than one culture/locale can have the same name.
- Windows Vista Microsoft Locale Builder Tool
- Klingon in pIqaD Windows Vista Custom Locale
- ISO 8601 Week of Year format in Microsoft .Net
- Custom Time Zones in Windows
- IDN Mitigation API dll needs to be explicitly linked
2005 28
- What's my Encoding Called?
- What Version of Unicode Does X Support?
- Custom Locales vs Custom Cultures in Windows Vista / .Net Framework
- Custom and Synthetic (Windows ELK) RegionInfos in .Net 2.0
- Creating a Custom Culture (Locale) From Microsoft-ish LDML
- Klingon Custom Culture/Locale MS LDML File
- CultureInfo.Name, ToString, LCID & CompareInfo.Name
- Avoid treating binary data as a String.
- Code Page 21027 "Extended/Ext Alpha Lowercase"
- New XPSP2 Locales Available
- Microsoft Internationalized Domain Names (IDN) Mitigation APIs 1.0 Released
- Custom Locales in Windows Vista (Longhorn)
- Encoding/Decoding/Crypting and buffer lengths
- Culture data shouldn't be considered stable (except for Invariant)
- .Net v2.0 (Whidbey) has some changed culture month/day names.
- CultureInfo Caching and ClearCachedData()
- UTF8 Security and Whidbey Changes
- "Precomposed" and "Composite" Characters in Windows APIs
- MultiByteToWideChar ignores MB_PRECOMPOSED behavior for UTF-8 and UTF-7
- How the various CultureInfo names and tags behave.
- Try to identify cultures by string name instead of LCID
- Whidbey Beta 2 bug with CreateSpecificCulture() for Neutral Custom Cultures.
- Don't Use Encoding.Default
- What's the difference between an Encoding, Code Page, Character Set and Unicode?
- "So Why Isn't Latin Shipped With the Framework?"
- Whidbey .Net 2.0 Custom Culture Example (Beta 2)
- What's with Encoding.GetMaxByteCount() and Encoding.GetMaxCharCount()?
- About My Blog