Raku Advent Calendar
One article on Raku per day, until Christmas. Full list of 2025 Raku Advent Blog Posts It's that time of the year Welcome to the Raku Advent Calendar, where we share one Raku article a day until Christmas. This is going to be the 16th year in a row with a Perl 6 or Raku…
- Posts
- 206 from 16 Oct 2019 to 28 Feb 2026
- Posting
- weekly (26 in the last year)
- Kind
- magazine
- Feed
- https://raku-advent.blog/feed/
2026 1
2025 25
- Day 25 – Raku 2025 Review
- Day 24 – Maze Making Using Graphs
- Day 23 – A Day Late and A Fish Short
- Day 22 – Numerically 2026 Is Unremarkable Yet Happy
- Day 21 – A Terminal’s Tale
- Day 20 – We’re Walking On The Air
- Day 19 – Welcome to the Megadungeon
- Day 18 – Hallo, Wêreld!
- Day 17 – An issue with evaluation
- Day 15 – An expression language for Vixen
- Day 14 – Taming Concurrency
- Day 13 – Christmas Crunching Part II
- Day 12 – Mathematician’s Yahtzee
- Day 11 – Raku To The Stars
- Day 10 – Santa’s Finance Department
- Day 9 – Monadic programming examples
- Day 8 – HARC The Herald Angels Sing
- Day 7 – Allowing for fewer dollars
- Day 6 – Robust code generation combining grammars and LLMs
- Day 5 – Tools for Gnome::Gtk4
- Day 4 – Gift yourself a merry little PDF journal
- Day 3 – Christmas Crunching Part I
- Day 2 – Doing Data Science with Raku
- Day 1 – Dancer, Dasher and Dosh (LLM-powered shell commands)
- The 2025 Raku Advent Posts
2024 26
- The 2024 Raku Advent Posts
- Day 25 – Raku 2024 Review
- Day 24 – In Search of the Essence of Raku
- Day 23 – Santa’s Print Shop
- Day 22 – Wrapping a Christmas Present
- Day 21 – Dam Mega Christmas
- Day 20 – Re-introducing a Raku plugin for IntelliJ IDEA
- Day 19 – Wrapping Scripts
- Day 18 – Happy™ Xmas
- Day 17 – Chebyshev Polynomials and Fitting Workflows
- Day 16 – Revision gating in Rakudo core
- Day 15 – Matching Maps
- Day 14 – Playing around with the new documentation components
- Day 13 – Content Storage For Raku Distributions
- Day 12 – Graphs in Raku
- Day 11 – Counting up concurrency
- Day 10 – How to give a Raku talk at TPRC – and why you should
- Day 9 – The end of the year
- Day 8 – Yet More Abilities for Iterables
- Day 7 – Conditionally Writeable Attributes
- Day 6 – Creating a presentation hosted on a Gemini capsule
- Day 5 – Generating an HTML Dashboard With Vanilla Raku
- Day 4 – Don’t use Forsyth-Edwards Notation to play chess with LLMs
- Day 3 – Merry Cromas
- Day 2 – WAT LLM coding tool do you want for Christmas?
- Day 1 – Rendering down for Christmas
2023 26
- The 2023 Raku Advent Posts
- Day 25 – Raku 2023 Review
- Day 24 – Streamlining AI vision workflows
- Day 23 – Optimizing Raku programs with Zig
- Day 22 – The Magic Of hyper
- Day 21 – Using DALL-E models in Raku
- Day 20 – Craggy Christmas Chronicles
- Day 19 – Autogenerating Raku bindings!
- Day 18 – Dissecting the Go-Ethereum keystore files using Raku tools
- Day 17 – Writing some horrible Raku code this Christmas!
- Day 16 – It’s Too Generic; Please Instantiate!
- Day 15 – An Object Lesson for the Elven
- Day 14 – The Magic Of Q (Part 2)
- Day 13 – Networks Roasting on an Open Fire, Part 3: Feeling Warm and Looking Cool
- Day 12 – Perspectives on RakuDoc Version 2
- Day 11 – Networks Roasting on an Open Fire, Part 2: Axes to Grind
- Day 10 – The Magic Of Q
- Day 9 – Networks Roasting on an Open Fire, Part 1: Whipuptitude
- Day 8 – Make it Snow 2.0: The Snowfall Strikes Back
- Day 7 – The Magic Of $/
- Day 6 – The Future Of POD6
- Day 5 – The Elves go back to Grammar School
- Day 4 – Embedding a stack-based programming language in Raku
- Day 3 – Helping the Elves Sort Their Mail
- Day 2 – An update on raku.land
- Day 1 – Rocking Raku Meets Stodgy Debian
2022 28
- The 2022 Raku Advent Posts
- Day 25: Rakudo 2022 Review
- Day 24: He’s making a list… (part 2)
- Day 23: Sigils followup: semantics and language design
- Day 22: He’s making a list… (part 1)
- Day 21: Raku and I: Journey begin …
- Day 20: Sigils are an underappreciated programming technology
- Day 19: A few modules to ease working with databases in Raku applications
- Day 18: Something else
- Day 17: How to clarify which parts of the documentation change
- Day 16: Santa CL::AWS (part 2)
- Day 15: Junction transformers
- Day 14: Trove – yet another TAP harness
- Day 13: Virtual Environments in Raku
- Day 12: RedFactory
- Day 11: Santa CL::AWS
- Day 10: SparrowCI pipelines cascades of fun
- Day 9: Something old, something borrowed, something new, something stashed
- Day 8: I’ll Let You Know Later
- Day 7: .hyper and Cro
- Day 6: Immutable data structures and reduction in Raku
- Day 5: Malware and Raku
- Day 4: Give the gift of time
- Day 3: Santa and the Rakupod Wranglers
- Day 2: Less Variable Wattage = More Flow
- Day 1: SparrowCI pipelines for everything
- Advent::Calendar
- All the blog posts of 2021
2021 26
- Day 25 – Future-proofing the Raku Programming Language
- Day 24 – Packaging and unpackaging real good
- Day 23 – The Life of Raku Module Authoring
- Day 22 – Santa Claus is Rakuing Along
- Day 21 – Santa Claus is Rakuing Along
- Day 20 – Create beautiful text charts
- Day 19 – Let it Cro
- Day 18 – Santa and the Magic Tree (M-Tree)
- Day 17 – Generic data structure traversals with roles and introspection
- Day 16 – Reindeer Express
- Day 15 – 1 year of Comma
- Day 14 – Santa Claus is Rakuing Along
- Day 13 – Coloring your tools holidays
- Day 12 – A long journey to Ethereum signatures
- Day 11 – Unix philosophy without left-pad, Part 2: Minimizing dependencies with a utilities package
- Day 10 – Java Annotations in Raku or my @annotation is role;
- Day 9 – Raku code coverage
- Day 8 – Practice… on Advent of Code
- Day 7 – Neural Nets in Raku (Part 1)
- Day 6 – Following the Unix philosophy without getting left-pad
- Day 5 – Santa Claus is Rakuing Along
- Day 4 – Santa’s OCD Sorted
- Day 3 – Silently
- Day 2 – Rotation of Log files in a nutshell
- Day 1 – Batteries Included: Generating Thumbnails
- It’s that time of the year… again
2020 48
- Day 25: Reminiscence, refinement, revolution
- Day 24: Christmas-oriented programming, part deux
- Day 23: Christmas-oriented design and implementation
- Day 22: What’s the point of pointfree programming?
- Day 21: The Story Of Elfs, and Roles, And Santas’ Enterprise
- Day 20: A Raku in the Wild
- Day 19: Typed Raku, Part 2: Taming Behaviour
- Day 18: Typed Raku, Part 1: Taming State
- Day 17: Becoming a Time Lord in Raku
- Day 16: Writing faster Raku code, Part II
- Day 15: Rudolph on Raku
- Day 14: Writing Faster Raku code, Part I
- Day 13 – Helping the Github Action elves
- Day 12: That Raku feeling
- Day 11: Santa Claus TWEAKs with a Class
- Day 10: My 10 commandments for Raku performances
- Day 9: Getting Windows Memory Usage with NativeCall
- Day 8: Raku web templating engines: boost up the parsing performance
- Day 7: Mixing Bash and Raku Using Sparrow
- Day 6: Declarative APIs, easy peasy with Raku
- Day 5: Raku & Pakku
- Day 4: Parsing Clojure namespace forms using Raku grammars
- Day 3: Literate Programming with Raku
- Day 2: Perl is dead. Long live Perl and Raku.
- Day 1: Why Raku is the ideal language for Advent of Code
- It’s that time of the year
- RFC 265: Interface polymorphism considered lovely
- RFC 28, by Simon Cozens
- RFC 84 by Damian Conway: => => =>
- RFC 200, by Nathan Wiger: Revamp tie to support extensibility
- RFC 159, by Nathan Wiger: True Polymorphic Objects
- RFC 188, by Damian Conway: Objects: Private keys and methods
- RFC 307, by Simon Cozens
- RFC 190, by Damian Conway: NEXT pseudoclass for method redispatch
- RFC22: Control flow: Builtin switch statement, by Damian Conway
- RFC 43: Integrate BigInts (and BigRats) Support Tightly With The Basic Scalars
- RFC 54, by Damian Conway: Operators: Polymorphic comparisons
- RFC 64: New pragma ‘scope’ to change Perl’s default scoping
- RFC 5, by Michael J. Mathews: Multiline comments
- RFC 225: Superpositions (aka Junctions)
- RFC 168, by Johan Vromans: Built-in functions should be functions
- RFC 145, by Eric J. Roode: Brace-matching for Perl Regular Expressions
- RFC 137: Perl OO should not be fundamentally changed.
- Sixy POD
- RFC 25, 76, 193: Worthy picks by Damian Conway
- RFC 112 by Richard Proctor: Assignment within a regex
- RFC1: Threads
- 20 years ago tomorrow
2019 26
- Happy new year!
- Day 24: The Grinch of Raku, Part 2: Hold Your Horses
- Day 23 – A Raku Advent Helper
- Day 22: Off Course
- Day 21: Searching for a Red gift
- Day 20 – Raku from Perl: Transforming Old Perl Code (Part 2)
- Day 19 – Functional Programming with Raku
- Day 18: What is my concurrent or parallel Raku program doing?
- Day 17: Maze Maker for Fun
- Day 16: Raku powered jmp-ing to the coalface
- Day 15 – Santa had too much eggnog
- Day 14 – Thinking Beyond Types: an Introduction to Rakudo’s MOP
- Day 13 – A Little R&R
- Day 12 – Making a simple bot in Raku
- Day 11 – Packaging with Libarchive
- Day 10 – A Teaser
- Day 9: a chain (or Russian doll) of containers
- Day 8 – Parsing Firefox’ user.js with Raku (Part 2)
- Day 7 – Parsing Firefox’ user.js with Raku
- Day 6 – Put some (GitHub) Actions in your Raku (repositories)
- Day 5 – Modular Raku Command Line Apps
- Day 4 – Not tripping over tripcodes
- Day 3 – Stack Frame Reduction
- Day 2 – CRUD with Cro::HTTP, a tutorial
- Day 1 – Raku from Perl: Transforming Old Perl Code
- A Raku Advent Calendar